RVOSD v6 and Dragonlink V3

bovick

Well-Known Member
If I understand correctly, you've already tried 8 channel setup on TX and RX?
I had a very similar glitch trying to use PPM from a TFR4-B RX on FASST with RVOSD 5.1 & 6. Using a different PPM enabled RX worked but any one of multiple TFR4-B rxs would not work on PPM... I never got exactly what caused this with RVOSD, but one possible solution would be to try using PWM instead of PPM and see if you still have a problem.


Here is a quote from RV on a previous 2011 post that may be helpful:
"Repeat time should be less than 30mS, blank time should be more than 3.520 mS. I think all the problems with combined PPM is because some radios are using more than 30mS of repeat time. For next firmware update I will increase repeat time period required to validate the frame. "
 

kbirand

Well-Known Member
Yes tried the 8ch setup. Will try the pwm just to see it.
Draginlink is already started working on it, they have send me 2 different firmwares with different delay rates. But Still no luck.
Actually if RVOSD and Dragon could contact with each other the could probably solve this in seconds.
 

kbirand

Well-Known Member
Alex, on RCgroups Bovick mentioned this :

Bovick--Here is a quote from RV that might possibly be helpful here:
"Repeat time should be less than 30mS, blank time should be more than 3.520 mS. I think all the problems with combined PPM is because some radios are using more than 30mS of repeat time. For next firmware update I will increase repeat time period required to validate the frame. "

Dennis/Dragonlink--Argh, so they actually require a frame-length of less than 30 ms, even for 12 channels? We're using 30 ms framelength for 12 channels..
Nevertheless, as it works with v. 1.9 I'll do some comparisons and see if there's anything obvious

Bovick--Please note that the quote above was from a post that is several years old and he indicates that next firmware should change this.. so best to check with RangeVideo guys on this to see how the more recent firmware(s) behave.

If you can help us with this we could actually help them find a solution faster.
They can not replicate the problem since they do not have RVOSD, but already they have sent me 3 firmwares to test..
 
Last edited:

Alex Villa

Super Moderator
"Repeat time should be less than 30mS, blank time should be more than 3.520 mS. I think all the problems with combined PPM is because some radios are using more than 30mS of repeat time. For next firmware update I will increase repeat time period required to validate the frame. "
Yes, this is already changed. Now RVOSD will check the combined PPM frame to repeat at least one every ~106mS, will end the frame decoding if a pulse greater than 3.520mS is detected. You do probably have a different problem.

Make sure the menu item R/C receiver connected is set to Yes and Rx input type set to Combinned PPM. Enter PPM configuration sub-menu. And check the values in mS do change. Make sure your Rx is receiving power RVOSD does not supply power unless a BEC is plugged to any of its inputs/outputs.
 

kbirand

Well-Known Member
Thank you Alex, I have passed frame values to Dragonlink...

I assume the second paragraph is copy paste :) If I do not know how to connect a receiver I should quit the hobby ;)
 
Top