RVOSD G5-G6 instructions (work in progress...)

thanks dudes. but is it supposed to work like that? this is one of the most expensive flight control in the market. we should expect it's performance to be in line too. or at least perform as advertised.

I could see in your video your heading changed about 60 degrees from the original when heading hold is set, exactly what my plane did. surely this is a bug that needs to be addressed?
 

grofrano

Member
Hello, I'm configuring my RVOSD6.
I'm using M6.06 G6.02

A 3-position switch is assigned to Aux channel (PPM) and a Knob is assigned to Aux2 channel (PPM)

I can change RVOSD screen perfectly when I toggle up the 3-position switch.

Now, when I toggle down the 3-position switch, the AP change to MANUAL or AP Flight Modes.

When is in MANUAL MODE the servos only responds to TX sticks movements.

When is in AP, the flight mode is selected by the knob. My doubt is that in RTH, HH, LF, PH and WS I can't control any servo (just the throttle). In FBW mode I can control the servos.

Is this normal ?

Thanx for your help !!!
 
Last edited:

ommadawn

Well-Known Member
Its normal.
Those are the Autopilot modes. FBW is a pilot assist mode that interprets your stick movements and applies the selected flight attitude based on how you have configured the maximum pitch and bank angles.
Position hold will take over and fly figure 8 or orbits around the selected GPS point that you activated it at.
The others are self explanatory.
 

viper1

Well-Known Member
Also worth mentioning is that (in flight) your controls are frozen during the time you browse through the menu so make sure you have a stable and level attitude before you go in the menu.

I sometimes have to bail out of the menu quickly to correct the plane for example when a gust of wind has changed the attitude of the plane.

Just something to be aware of.
 

ommadawn

Well-Known Member
+1. Absolutely. Be well practiced in toggling the 3 position switch so that you can return to normal flight mode without thinking about which way to flick.
Sometimes stuff happens and you need to be able to bail out instantly. EG none of the a/p mode will be able to handle a spin. FBW will actually make it worse by trying to pitch the nose up, regardless of how much down elevator you put in.
 

bovick

Well-Known Member
+1. Absolutely. Be well practiced in toggling the 3 position switch so that you can return to normal flight mode without thinking about which way to flick.
Sometimes stuff happens and you need to be able to bail out instantly. EG none of the a/p mode will be able to handle a spin. FBW will actually make it worse by trying to pitch the nose up, regardless of how much down elevator you put in.
Yep, this is really key. I had two crashes because of freaking out and flicking the switch the wrong way :rolleyes:
Nice to be able to set up a single three position switch with positions being manual / selected flight mode / rth. Then using this same switch set up for all fpv platforms makes for quick easy split second action when needed. Saved my bacon many times... but have yet to get a clear idea of how to do this with rvosd without toggling out of the current flight mode 1/2 the time.
 

grofrano

Member
Hello, my DragonLink receiver has a RSSI output pin wich I connect directly to RVOSD Temp/RSSI input port.
All is working fine.

Have I need to put a 10K resistor between them ?

Thank you very much for your help !!
 
Purchased RVOSD 6, but could not use it due some problem in the RVOSD, best known to the manufacturer. I am not getting any fruitful help from the super modulator. He is giving some general instruction which is of no use as even after passing weeks together by RVOSD is not operational. The problem from the instruction given by Alex are as follows:
1. The thread given to down load Picket 2 v2.61 is not working (the link belongs to 2008)
2. I down loaded the software v2.61 from forum but when installing the firm ware for the Video board, the message displayed at the end "verification of configuration failed". When the roved is re-powered (cycled) again the screen is screen 0, with remote when screen is switched to 2/4 at call sign 000000/on screen, but from there when r/c wizard is selected to execute ,it switches to debug screen again.
3. It is obvious that RVOSD is very clumsy and problematic OSD and without proper customer support system.
4. It seems I will forced to ground RVOSD 6, as I am not getting any support from super modulator.
5. The Pickit 2 v 2.61 I am using is https://www.dropbox.com/sh/5c8nr5mhcaoex5z/AAC-98nkqbvsVWUSrbtwtFxza?dl=0
6. Various screen shot are View attachment 3029 View attachment 3031View attachment 3032View attachment 3033View attachment 3033View attachment 3032
 

viper1

Well-Known Member
Purchased RVOSD 6, but could not use it due some problem in the RVOSD, best known to the manufacturer. I am not getting any fruitful help from the super modulator. He is giving some general instruction which is of no use as even after passing weeks together by RVOSD is not operational. The problem from the instruction given by Alex are as follows:
1. The thread given to down load Picket 2 v2.61 is not working (the link belongs to 2008)
2. I down loaded the software v2.61 from forum but when installing the firm ware for the Video board, the message displayed at the end "verification of configuration failed". When the roved is re-powered (cycled) again the screen is screen 0, with remote when screen is switched to 2/4 at call sign 000000/on screen, but from there when r/c wizard is selected to execute ,it switches to debug screen again.
3. It is obvious that RVOSD is very clumsy and problematic OSD and without proper customer support system.
4. It seems I will forced to ground RVOSD 6, as I am not getting any support from super modulator.
5. The Pickit 2 v 2.61 I am using is https://www.dropbox.com/sh/5c8nr5mhcaoex5z/AAC-98nkqbvsVWUSrbtwtFxza?dl=0
6. Various screen shot are View attachment 3029 View attachment 3031View attachment 3032View attachment 3033View attachment 3033View attachment 3032
IMG_1340.jpg is OK, it always gives a error of verification only with one of the boards, I can not remember if it is with the Main, or Graphics board.

All your other screenshots are normal as far as I can tell, at least after a firmware upgrade. Your graphics are locked, you have to send Alex a PM with the ID in it (see IMG_1345.jpg). AS PER INSTRUCTIONS ! http://www.rangevideo.com/forum/showthread.php?814-Latest-firmare-version-for-your-OSD&p=6834#post6834
Read from: "-After this you have to cycle power to the OSD, so it restarts etc etc. "
 
Last edited:
IMG_1340.jpg is OK, it always gives a error of verification only with one of the boards, I can not remember if it is with the Main, or Graphics board.

All your other screenshots are normal as far as I can tell, at least after a firmware upgrade. Your graphics are locked, you have to send Alex a PM with the ID in it (see IMG_1345.jpg). AS PER INSTRUCTIONS ! http://www.rangevideo.com/forum/showthread.php?814-Latest-firmare-version-for-your-OSD&p=6834#post6834
Read from: "-After this you have to cycle power to the OSD, so it restarts etc etc. "
Mine is RVOSD 6, and some where I read that RVOSD 6 does not require an unlock code, do I still need to send a PM to Alex?
 
Thanks a lot Viper1, with your guidance only I came to know that even with the configuration verification error the software was updated. I think this should be included in the instruction if it is normal feature. Unnecessary I did wasted my time searching here and there.
 

Pegru

Well-Known Member
Thanks a lot Viper1, with your guidance only I came to know that even with the configuration verification error the software was updated. I think this should be included in the instruction if it is normal feature. Unnecessary I did wasted my time searching here and there.
Use the "search" function in forum, type "flashing instructions" and you will find everything you are looking for.
 

degan367

New Member
Hi, just installed my RVOSD 6 in my bix3. Just wondering what the Aux3 is used for in the PPM configuration? I am also using a DL micro reciever with a DL advanced Tx. I'm using the digital RSSI and have the PWM used for it. PPM packets dont seem to work but the PWM did, it it OK to use the PWM with the dragon link for RSSI?
 
Last edited:
Top